Напишите программу которая будет решать эти задачи с оператором цикла for или while...

0 голосов
34 просмотров

Напишите программу которая будет решать эти задачи с оператором цикла for или while задачи на картинки


image

Информатика (35 баллов) | 34 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Задача №2
uses crt;var  x,i: integer;  begin cls;  write('x= '); readln(x);  for i:=1 to x do    if (x mod i)=0 then writeln(i);end.
Задача №1
uses crt;var  x,a,b,c,i: integer;  begin cls;  for i:=100 to 999 do  begin   a:= i div 100;   b:= (i - a*100) div 10;   c:= (i - a*100 - b*10);   if (a+b+c)*(a+b+c)*(a+b+c)=i then   begin    writeln(i);    inc(x);   end;  end;  if x=0 then write('Такого числа нет');end.
Задача №3
uses crt;var  x,a,b,i: integer;  begin cls;  for i:=10 to 99 do  begin   a:= i div 10;   b:= i - a*10;   if a=(b*2) then writeln(i);  end;end.

(630 баллов)