Напишите программу, которая считывает натуральное число n и выводит ** экран случайное...

0 голосов
63 просмотров

Напишите программу, которая считывает натуральное число n и выводит на экран случайное натуральное число, меньшее n и оканчивающееся на 1. Гарантируется, что будет ввeдено натуральное число 1


Информатика (17 баллов) | 63 просмотров
Дан 1 ответ
0 голосов

Программа:

program MrSolution;

var n: integer;

function MrSolutionRandom(topBorder: integer):integer;

var rand: integer;

begin

 randomize;

 rand:= random(0, topBorder-1);

 MrSolutionRandom:= rand-rand mod 10+1;

end;

begin

  write('Введите натуральное число, кроме 1 >> ');

  repeat

    readln(n);

  until n<>1;

  writeln(MrSolutionRandom(n));

end.

(8.7k баллов)
0

За что 3 звезды поставили? Спасибо за благодарность за мой труд.