Написать программу, которая выдает таблицу значений функции Y = 6x2 + arctg(x), угол...

0 голосов
100 просмотров

Написать программу, которая выдает таблицу значений функции Y = 6x2 + arctg(x), угол вводится в градусах. Перевод угла в радианы предусмотреть в программе. Начальное и конечное значение вводит пользователь. Предусмотрите проверку корректности (начало меньше конца) #include #include #include #include void main(){setlocale(LC_ALL,"rus");float x,y1,y2,y,A;printf("Введите начальное значение x:");scanf ("%f",&y1);printf("Введите конечное значение x:");scanf ("%f",&y2);if (y1>y2&&y == 3)for (y = y1;y < y2;y++){A=y*3,14/180;x=6*pow(x,2) + atan(x);printf("x=%f\n",x);}return 0;}в чем ошибка? скажите пожалуйста


Информатика (98 баллов) | 100 просмотров
Дан 1 ответ
0 голосов

Ответ:

Объяснение:

#include

#include

#include

int main()

{

setlocale(LC_ALL, "rus");

float x, xn, n, Y,       y, A;

printf("Введите начальное значение x:");

scanf("%f", &x);

printf("Введите конечное значение x:");

scanf("%f", &xn);

 

printf("Введите шаг :");

scanf("%f", &n);

 

 

while (x <= xn)  </p>

{

     A = x * 3, 14 / 180;

 Y = 6 * pow(x, 2) + atan(A);

   

 x += n;

   

 printf("%5.2f -> %5.2f\n", x, Y);

   }

 

return 0;

}

(33 баллов)
0

#include
#include
#include
int main()

{

setlocale(LC_ALL, "rus");

float x, xn, n, Y, y, A;

printf("Введите начальное значение x:");

scanf("%f", &x);

printf("Введите конечное значение x:");

scanf("%f", &xn);

if(x <= xn)<br /> for(x; x < xn; x+=3) // x+=3 шаг
{
A = x * 3, 14 / 180;

Y = 6 * pow(x, 2) + atan(A);

printf("%5.2f -> %5.2f\n", x, Y);

}
else printf("Начальное больше конечного значения");


return 0;
}