Напишите программу, которая выводит случайные числа от 10 до 20 и подсчитывает чётные...

0 голосов
85 просмотров

Напишите программу, которая выводит случайные числа от 10 до 20 и подсчитывает чётные числа


Информатика (12 баллов) | 85 просмотров
Дан 1 ответ
0 голосов

var

 i,a,count,sum:integer;

begin

 count:=0; sum:=0;

 write('Кол-во чисел: '); readln(a);

 for i:=1 to a do

   begin

     a:=random(11)+10;

     write(a:4);

     if a mod 2 = 0 then

       begin

         inc(count);

         sum:=sum+a;

       end;

   end;

 writeln;

 write('Sum: ',sum,' Count: ',count);

end.1

(320 баллов)