Помогите пж 1)** вход программы подается количество вводимых чисел, а затем сами числа....

0 голосов
65 просмотров

Помогите пж 1)На вход программы подается количество вводимых чисел, а затем сами числа. Определить сколько вводимых чисел кратных 13. Вывести количество этих чисел. 2)На вход программы подается количество вводимых чисел, а затем сами числа. Числа положительные, не превышающие 100. Определить максимальное число в последовательности. Вывести это число.


Информатика (12 баллов) | 65 просмотров
Дан 1 ответ
0 голосов

1)

var

 a,i,count:integer;

begin

 readln(a);

 count:=0;

 for i:=1 to a do  

   begin

     readln(a);

     if a mod 13 = 0 then

       inc(count);

   end;

 writeln('Count: ',count);

end.

2)

var

 a,i,max:integer;

begin

 readln(a);

 for i:=1 to a do  

   begin

     repeat

       readln(a);

       if a>100 then

         writeln('Error.Repeat');

     until a

     if i = 1 then

       max:=a

         else

           if max < a then

             max:=a;

   end;

 writeln('Max: ',max);

end.

(320 баллов)