Составьте программу ,которая позволяет удалить символы t из строки s.Строка s и символ...

0 голосов
91 просмотров

Составьте программу ,которая позволяет удалить символы t из строки s.Строка s и символ t,который надо удалить,вводятся с клавиатуры


Информатика (299 баллов) | 91 просмотров
0

обязательно именно удалять символ в строке? можно просто при выводе фильтровать символы. если важен только результат, то можно так сделать, если решение, то надо удалять.

0

Важно решение

Дан 1 ответ
0 голосов
Правильный ответ

Тогда вот, все по букве задания

var
  s : string;
  t : char;
  i : integer;
begin
  readln (s);
  read (t);
  i := 1;
  while (i <= length (s)) do<br>  begin
    if s[i] = t then delete (s, i, 1)
    else i := i + 1;
  end;
  writeln (s);
end.

(4.6k баллов)
0

Спасибо огромное)