Помогите пожалуйста с контрольной по Информатике! Даю 70 Баллов!
Контрольная работа «Разработка алгоритмов и программ»
1.Языковые конструкции с помощью которых в программах записываются действия, выполняемые в процессе решения задачи, называются:
а) операндами; в) данными;
б) операторами; г) выражениями.
2.Что из нижеперечисленного не входит в алфавит языка Паскаль?
а) Латинские строчные и прописные буквы; в) знак подчеркивания;
б) русские прописные и строчные буквы; г) служебные слова.
3.Целые числа относятся к типу данных:
а) real; в) string;
б) integer; г) boolean.
4.Для ввода данных в Паскале используется оператор:
а) print; в) readln;
б) write; г) begin.
5.Для вычисления модуля числах х используется функция:
а) abs(x); в) int(x);
б) sqr(x); г) sqrt(x).
6.Определите значение переменной c после выполнения фрагмента программы:
a:= 60;
b:= 10;
a:= a - b*3;
if a
7. Используя следующие фрагменты составьте оператор цикла с условием.
а) a:=c+1; г) then;
б) for; д) do;
в) a>b; е) while.
8.В каком из условных операторов допущена ошибка?
а) if a
б) if a>b then max:=a; else max:=b;
в) if b=0 then write (‘Деление невозможно’);
9.Определите значения переменной s после выполнения фрагмента алгоритма:
а)
s:= 0;
m:=6:
for i:=3 to m do
s:=s+i;
б)
s:=0;
i:=5;
while i>0 do
begin
i:=i-1;
s:=s+i;
end;