Написать программу, которая вычисляет сумму всех четных чисел в диапазоне от 1 до 16​

0 голосов
105 просмотров

Написать программу, которая вычисляет сумму всех четных чисел в диапазоне от 1 до 16​


Информатика (52 баллов) | 105 просмотров
Дано ответов: 2
0 голосов

Ответ:

Объяснение:

var

   i, n, sum: integer;

begin

   writeln('Введите n');

   readln(n);

   ///Тут возможны два решения, с циклом и без. Вот первое:

   sum := 0;

   for i := 1 to n do

       if i mod 2 = 0 then

           sum := sum + i;

   writeln(sum);

   

   ///Второе, более быстрое, использующее формулу суммы первых членов арифметической прогрессии:

   if n mod 2 = 1 then n := n - 1;

   writeln(((2 + n) div 2) * n div 2);

end.

(526 баллов)
0 голосов

Ответ

Если пишешь на Паскале то-

1 Program Summ;   // Название программы

2 Var i, summ: integer   // Объявляем переменные: i для числа, summ для суммы. Обе переменные — целочисленные (integer)

3 Begin   // Начало программы

4  Summ:=0;   // Обнуляем сумму

5   Writeln('Write n');   // Просим юзера ввести n

6  For i:=1 to n do   // Цикл для i от одного до n

7   Begin   // Начало цикла

8      If i mod = 2 then   // Условие для числа — число должно быть четным

9      Begin   // Начало цикла

     10   summ:=summ+i;   // Прибавляем к сумме число (если выполняется условие, см. выше)

 11    End;   // Конец цикла для If

12  End;   // Конец цикла для For

13  Writeln(summ);   // Выводим сумму

  14 Readln;   // Ждем нажатия Enter (чтобы программа не закрывалась сразу после вывода суммы, иначе юзер не успеет прочитать ее)

15 End.   // Конец программы

Объяснение:

(74 баллов)