ЛЮДИ ДОБРЫЕ ПОМОГИТЕ УМОЛЯЮ ПОЖАЛУЙСТА! Напишите программу в Паскале, которая выводит...

0 голосов
62 просмотров

ЛЮДИ ДОБРЫЕ ПОМОГИТЕ УМОЛЯЮ ПОЖАЛУЙСТА! Напишите программу в Паскале, которая выводит случайное число в промежутке от 15 до N. Значение N вводится с клавиатуры и N ( знак больше)15.


Информатика (33 баллов) | 62 просмотров
Дан 1 ответ
0 голосов

Должно работать это:

var N,r:integer; //нужные нам переменные

begin //СТАРТУЕМ!

 writeln('Впишите N. . .');  //просим ввести N

 readln(N); //получаем N

 randomize; //без этого рандом выдаёт одно и то же

 r := random(N-15+1)+15; //формула раандома

 writeln(r); //выводим рандомное число

end. //выключаем программу

(156 баллов)
0

Блин, чувак, ты герой, спасибо тебе о великий!

0

понимаю.