ДАЮ 100 БАЛЛОВ! Для решения задач вам понадобиться:- связать ввод и вывод программы...

0 голосов
113 просмотров

ДАЮ 100 БАЛЛОВ! Для решения задач вам понадобиться:- связать ввод и вывод программы соответственно с файлом, с которого будете читать данные, и с файлом, в который будете выводить результат ( ifstream имя_файла_1; ofstream_имя_файла_2);- открыть файл с данными и открыть файл, в который будете выводить результат (имя_файла_1.open ( "input.txt" ); имя_файла_2.open ( "output.txt" );)- читать данные, пока не закончится файл (while ( !имя_файла.eof() ));- вывести число с заданным количеством знаков после запятой (имя_файла << fixed << setprecision (количество_знаков) << результат);- закрыть файлы (имя_файла.close())Желательно с объяснением к каждой строкеС++Найти минимальное и максимальное из чётных положительных чисел, записанных в файле input.txt . Количество чисел неизвестно. Если в файле нет чётных положительных чисел, нужно вывести число 0. Результат записать в файл output.txt .Входные данныеЦелые числа записаны в файле input.txt в столбик, по одному в строке. Ввод заканчивается тогда, когда заканчиваются данные в файле.Выходные данныеПрограмма должна вывести в файл output.txt минимальное и максимальное из чётных положительных чисел, разделив их пробелом. Если в файле нет чётных положительных чисел, нужно вывести число 0.


Информатика (18 баллов) | 113 просмотров
Дан 1 ответ
0 голосов

Ответ:

f=open('input.txt')

g=open('output.txt','w')

s=[int(i) for i in f.read().split()]

s=[i for i in s if (i>0 and i %2 == 0)]

if s != []:

   print(str(min(s))+' '+str(max(s)), file = g)

else:

   print('0', file = g)

f.close()

g.close()

(34 баллов)