Напишите программу, которая находит частное (суммы всех четных чисел) / (Разность всех нечетных чисел), записанных в файле в столбик, и выводит результат в другой файл.
#include
using namespace std;
signed main() {
freopen("input.txt","r",stdin);
freopen("output.txt","w",stdout);
int x;
double sum = 0,dif = 0;
while(cin >> x){
if(x % 2 == 0)
sum += x;
else
dif -= x;
}
cout << sum/dif;</strong>
fclose (stdout);
паскаль
Язык нужный в вопросе указывают, а не после получения ответа.
не знал сори
у меня 2 подобные задачи за 50 баллов уже стоят не решенные, если можете помогите
// PascalABC.NET
begin
var (se, so) := (0, 0);
foreach var s in ReadLines('input.txt') do
var t := s.ToInteger;
if t.IsEven then
se += t
so += t
end;
WriteAllText('output.txt', (se / so).ToString)
end.