СРОЧНО!!! Напишите программу, которая вводит два целых числа и находит их произведение,...

0 голосов
119 просмотров

СРОЧНО!!! Напишите программу, которая вводит два целых числа и находит их произведение, не используя операцию умножения. Учтите, числа могут быть отрицательными. ЧЕРЕЗ ОПЕРАЦИЮ REPEAT.


Информатика (654k баллов) | 119 просмотров
Дан 1 ответ
0 голосов

Ответ:

Var

a,b,x,y,z:integer;

 begin

writeln('Введите первое число');

readln(a);

writeln('Введите второе число');

readln(b);

z:=b;

if b<0 then z:=-b; </p>

for y:=1 to z do  begin

  x:=x+a;

  end;

if b<0 then x:=-x; </p>

writeln('Произведение чисел = ',x);

end.

Объяснение:

вот и все

(269 баллов)
0

Вот слова Repeat я в решении не увидел