Напишите программу плиз отдам 100 баллов

0 голосов
29 просмотров

Напишите программу плиз отдам 100 баллов


image

Информатика (20 баллов) | 29 просмотров
0

Положительна понятно когда выводить, а неотрицательна когда рана 0 или как?

0

Программу можно писать на любом языке?

0

на паскале

0

помаги пж

Дан 1 ответ
0 голосов

Ответ:

program z1;

var i: integer;

a, x, f: real;

begin

writeln ('Программа вычисления функции f(x) = sin (2x) / sqrt (x)');

writeln ('При x, изменяющемя от 1 до 2 с шагом а');

writeln ('Введите шаг измениения функции (a>0)');

write ('a = ');

readln (a);

writeln ('i - номер строки');

writeln ('|--------------------------------------------------------|');

writeln ('|       Таблица функции f(x) = sin (2x) / sqrt (x)       |');

writeln ('|--------------------------------------------------------|');

writeln ('|    i    |      x     |      f      |     Значение      |');

writeln ('|--------------------------------------------------------|');

i:=0;

x:=1;

repeat

i:=i+1;

f:=sin (2*x) / sqrt (x);

if f > 0 then writeln ('|',i:5,'    |    ',x:0:3,'   |    ',f:0:3,'    |   положительная   |') else

if f < 0 then writeln ('|',i:5,'    |    ',x:0:3,'   |    ',f:0:3,'   |   отрицательная   |') else

writeln ('|',i:5,'    |    ',x:0:3,'   |     ',f:0:3,'   |      равна 0     |');

writeln ('|--------------------------------------------------------|');

x:=x+a;

until x > 2.0001

end.

Объяснение:

Программы будет выводит значение: положительная или отрицательная (а не неотрицательная, т.к. думаю, что там просто опечатка)

Программа допускает точность а до тысячных разрядов дробной части.

sin вычисляется в радианах

(2.2k баллов)
0

спасибо