Напишите программу, которая матрицу вида 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 выведет в виде: 1 5 9 13 2 6 10 14 3 7 11 15 4 8 12 16 Вспомните из материала 9 класса, как описывыются 2-мерные массивы в разделе var.
Фи... вывод по столбцам всего лишь...
begin
var a := MatrGen(4, 4, (i, j)-> 4 * i + j + 1);
a.Println(3);
Writeln;
for var j := 0 to 3 do
for var i := 0 to 3 do
Write(a[i,j]:3);
Writeln
end
end.