Написать программу вычисления величиныB = m(m-1)(m-2) … (m-(n-1)) , где m, n заданы...

0 голосов
35 просмотров

Написать программу вычисления величины


B = m(m-1)(m-2) … (m-(n-1))
,


где
m, n заданы
(m>n, m,n – натуральны
числа).


Информатика (31 баллов) | 35 просмотров
Дан 1 ответ
0 голосов
VAR
   n, m, ans, i: UInt64;
BEGIN
   Read(m, n);

   ans := m;
   For i := 1 to (n-1) do
      ans := ans*(m - i);

   Write(ans);
END.
(733 баллов)