Написать программу вычисления стоимости покупки с учетом скидки. Скидка в...

0 голосов
291 просмотров

Написать программу вычисления стоимости покупки с учетом скидки. Скидка в 3% предоставляется в том случае, если сумма покупки больше 1000 руб., в 5% – если сумма больше 1500 руб.


Информатика (12 баллов) | 291 просмотров
Дан 1 ответ
0 голосов

Ответ:

var

   s: real;

begin

   write('Введите сумму покупки: ');

   readln(s);

   if s > 1000 then

       s := s * (1 - 0.05)

   else if s > 500 then

       s := s * (1 - 0.03);

   

   writeln('Сумма покупки с учетом скидки: ', s);

end.

Подробнее - на Znanija.com - znanija.com/task/2175242#readmore

Объяснение:

(42 баллов)