Ребят помогите в паскале набрать. Считать произведение (при этом в программе нужно...

0 голосов
53 просмотров

Ребят помогите в паскале набрать. Считать произведение (при этом в программе нужно указать P=1) введенных с клавиатуры чисел до тех пор, пока не будет введено отрицательное число. Составить программу.


Информатика (12 баллов) | 53 просмотров
Дан 1 ответ
0 голосов

var

a:boolean;

p,new:integer;

begin

 a:=TRUE;

 p:=1;

 while a do

 begin

 readln(new);

 if new >= 0

 then p:= p * new

 else a:=FALSE;

 end;

 writeln(p);

end.


image
(4.0k баллов)