Срочно.Напишите программу. Петя и Валера решили А задач. Из них В задач решил Валера. Кто...

0 голосов
55 просмотров

Срочно.Напишите программу. Петя и Валера решили А задач. Из них В задач решил Валера. Кто из мальчиков решил задач больше и на сколько?


Информатика (16 баллов) | 55 просмотров
Дан 1 ответ
0 голосов

Ответ:

(см. объяснение)

Объяснение:

Возможный вариант решения задачи на Pascal ABC NET:

begin

 var a: integer := ReadInteger('Сколько задач решили Петя и Валера >>');

 var b: integer := ReadInteger('Сколько задач решил Валера >>');

 if((a-b)>b) then 'Петя решил на '.Concat((a-2*b).ToString).Concat(' задач больше, чем Валера.').Println

 else 'Валера решил на '.Concat((2*b-a).ToString).Concat(' задач больше, чем Петя.').Println

end.

(8.7k баллов)
0

Если хотите сделать программу более похожей на то, чему Вас учили в школе, замените ReadInteger на writeln(); readln(); и используйте writeln для вывода