ДАЮ 30 БАЛЛОВрешите задачу ** кумире плз. Напишите программу, которая в...

0 голосов
27 просмотров

ДАЮ 30 БАЛЛОВрешите задачу на кумире плз. Напишите программу, которая в последовательности натуральных чисел вычисляет сумму всех двузначных чисел, кратных 8. Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число: сумму всех двузначных чисел, кратных 8.


Информатика (12 баллов) | 27 просмотров
0

Язык программирования КУМИР

Дан 1 ответ
0 голосов

var

   a, count: integer;

begin

   count := 0;

   readln(a);

   while a <> 0 do begin

       if (a mod 8 = 0) then count := count + 1;

       readln(a);

   end;

   writeln(count);

end.

(26 баллов)
0

братан, язык КУМИР

0

а блен, сорян. я такой язык не знаю