Срочно Информатика, много баллов! Ребят нужно решения для 10 класса Пожалуйста, без...

0 голосов
60 просмотров

Срочно Информатика, много баллов! Ребят нужно решения для 10 класса Пожалуйста, без сложных функций простыми командами для 10 класса readinteger , split и другие такие функции не приветствуются!простое решение без char и т дPascal ABC1) С клавиатуры вводится символьная строка. Определите, сколько раз встречается в строке каждый из входящих в нее символов.2) С клавиатуры вводится предложение, в котором слова разделены пробелами. Определите, сколько слов в этом предложении начинается и заканчивается на одну и ту же бук(ВНИМАНИЕ! НЕ НАДО ИСПОЛЬЗОВАТЬ ТАКИЕ ФУНКЦИИ КАК chr, ord,include!)​​​


Информатика (395 баллов) | 60 просмотров
0

не пойму почему char нельзя считывать 1 решение можно сделать массивом char

Дан 1 ответ
0 голосов

Ответ:

1-

program qq;

var

s: string;

i, count: integer;

this_c: char;

begin

readln(s);

while (length(s) > 0) do begin

this_c := s[1];

count := 0;

while(pos(this_c, s) <> 0) do begin

delete(s, pos(this_c, s), 1);

count := count + 1;

end;

writeln('"', this_c, '": ', count);

end;

writeln;

end.

2-надо думать(

(80 баллов)
0

спасибо бро

0

как отметить лучший ответ?

0

обращайтесь.Через несколько дней под решением появится корона, нажмешь на неё и тадам,готово. Вроде так)

0

можешь помочь?

0

Напишите функцию, которая удаляет из переданной ей символьной строки все
символы, заключенные в угловые скобки '<' и '>' (вместе с этими скобками).

0

у меня есть этот вопрос зайди в профиль мой

0

ответишь и получишь баллы

0

Ок