Составить программу в Паскаль.

0 голосов
8 просмотров

Составить программу в Паскаль.


image

Информатика (146 баллов) | 8 просмотров
Дан 1 ответ
0 голосов

Ответ:

pascal

Объяснение:

var n, s:integer;

begin

 Write('Введите число: ');

 ReadLn(n);

 while n > 0 do

 begin

   if (n mod 10 < 6) then s := s + n mod 10;

   n := n div 10;

 end;  

 WriteLn(s);

end.

(1.1k баллов)
0

Спасибо

0

А почему при любом числе программа выводит 0?

0

исправил.... совсем уже загнался ;)