Составить программу паскаль

0 голосов
27 просмотров

Составить программу паскаль


image

Информатика (31 баллов) | 27 просмотров
Дан 1 ответ
0 голосов

Ответ:

готово

Объяснение:

Задача 1

var

 n: integer;

begin

 Write('Введите чило >>> ');

 ReadLn(n);

 if n mod 2 = 0 then

   WriteLn('четное')

 else

   WriteLn('нечетное')

end.

Задача 2

var

 n: integer;

begin

 Write('Введите год >> ');

 ReadLn(n);

 if (n mod 100) = 0 then

 begin

   if (n div 100) mod 4 = 0 then

     WriteLn(n, ' год - високосный')

   else

     WriteLn(n, ' год - не високосный');

 end

 else

   if n mod 4 = 0 then

     WriteLn(n, ' год - високосный')

   else

     WriteLn(n, ' год - не високосный');

end.

(1.1k баллов)