ПОМОГИТЕ СРОЧНО ПО ИНФОРМАТИКЕ ОТДАЮ ВСЕ БАЛЛЫ !!! 1.Заполнить двумерный массив N x N...

0 голосов
29 просмотров

ПОМОГИТЕ СРОЧНО ПО ИНФОРМАТИКЕ ОТДАЮ ВСЕ БАЛЛЫ !!! 1.Заполнить двумерный массив N x N случайными числами из интервала [-10; 10] и заменить максимальный элемент на противоположный по знаку. 2.Заполнить двумерный массив N x N случайными числами из интервала [-10; 10], найти минимальный элемент и увеличить его в два раза. Написать программу на языке Паскаль.


Информатика (40 баллов) | 29 просмотров
Дан 1 ответ
0 голосов

program gulkakh;

const n=5;

var a:array[1..n,1..n] of integer;   

i,j,k,max,stroka:integer;

begin

writeln('Исходная матрица:');

for i:=1 to n do   

for j:=1 to n do    begin   

 a[i,j]:=random(20)-10;   

 write(a[i,j],' ');   

  if j=n then writeln; 

  end;   

 stroka:=1;

max:=a[1,1];

for i:=1 to n do

for j:=1 to n do begin

if max

max:=a[i,j];

stroka:=i;

end;

end;

k:=n;

for i:=stroka to n-1 do

for j:=1 to n do

a[i,j]:=a[i+1,j];

k:=k-1;

writeln('Без удаленной строки:');

for i:=1 to k do 

 for j:=1 to n do begin

  write(a[i,j],' '); 

if j=n then writeln; 

end;

end.

(22 баллов)