СРОЧНО ПЖ Написать программу и начертить блок-схемы решения задач: Дан массив...

0 голосов
23 просмотров

СРОЧНО ПЖ Написать программу и начертить блок-схемы решения задач: Дан массив вещественных чисел, состоящий из 10 элементов. Найти максимальный элемент массива.


Информатика (12 баллов) | 23 просмотров
Дан 1 ответ
0 голосов

Ответ:

попробуй это. Тут еще с нахождением его номера

var a:array[1..100] of real;

    i,imax,n:integer;    

max:real;

begin

write('N= ');

readln(n);

for i:=1 to n do     read(a[i]);

writeln('-------------');

imax:=0;

max:=a[1];

for i:=1 to n do     if a[i]>max then

begin max:=a[i];imax:=i;

end;

writeln('max = ',a[imax],' nomer = ',imax);

readln;

end.

(30 баллов)