Напишите программу которая заполняет массив из 10 элементов случайными числами ** отрезке...

0 голосов
173 просмотров

Напишите программу которая заполняет массив из 10 элементов случайными числами на отрезке [50;150] и находит в нем минимальный и максимальный элементы и их номера


Информатика (16 баллов) | 173 просмотров
Дан 1 ответ
0 голосов

#include

#include

#include

#include

#include

#include

using namespace std;

signed main() {

   ios_base::sync_with_stdio(0);

   cin.tie(0);

   cout.tie(0);

   srand(time(NULL));

   const int N = 10;

   int a[N];

   int mx = -200, mn = 200;

   for(int i = 0; i < N; i++)

   {

       a[i] = rand() % 101 + 50;

       mn = min(mn,a[i]);

       mx = max(mx,a[i]);

   }

   cout << mx << " " << mn;</strong>

}

(688 баллов)