8.** вход программе подается натуральное число в конце которого стоят нули. Отрежьте от...

0 голосов
50 просмотров

8.На вход программе подается натуральное число в конце которого стоят нули. Отрежьте от правого края числа все нули. В ответ выведите полученное число.Питон помогите плиз​


Информатика (44 баллов) | 50 просмотров
Дан 1 ответ
0 голосов

Ответ:

a=list(input())

while a[-1]=='0':

   del a[-1]

print(''.join(a))

Объяснение:

Не оптимально конечно, но работает

(30 баллов)
0

что такое джоин

0

можешь сделать без него