Даю 100 баллов за решение через for Напишите программу, которая запрашивает число N, а...

0 голосов
48 просмотров

Даю 100 баллов за решение через for Напишите программу, которая запрашивает число N, а затем считает сумму чисел от 1 до N включительно, т.е. 1+2+3...+N.


Информатика (220 баллов) | 48 просмотров
Дан 1 ответ
0 голосов

Пожалуйста уточняйте на каком языке программирования нужно написать.

Для примера напишу на С++, но алгоритм будет тот же везде

//Создаем переменные n и sum

int n = 0;

int sum = 0;

//Вводим число n с клавиатуры.

cout << "Введите n: ";</strong>

cin >> n;

//Создаём цикл от 0 к числу которое мы ввели(включая его)

//Считаем сумму всех чисел которые идут до этого числа

for(int i = 0; i<=n; i++){</strong>

sum = sum + i;

}

//Выводим нашу сумму

cout << "Сумма: " << sum;</strong>

(915 баллов)
0

Pascal

0

Через Pascal Реши пожалуйста