Программирование с условным оператором Коробочка имеет форму прямоугольного...

0 голосов
79 просмотров

Программирование с условным оператором Коробочка имеет форму прямоугольного параллелепипеда с размерами X, Y, Z радиусом R. Составить программу, которая при указанных данных напечатает результат и какой стороной влезет.Пример: ввести размеры и радиус: X=3, Y=5, Z=7, R=10Составить условие для проверки прохождения коробочки.Печать ответа: "Коробочка влезет" или "Коробочка не влезет"


Информатика (40 баллов) | 79 просмотров
Дан 1 ответ
0 голосов

program box;

var

 x, y, z, r: integer;

 d: real;

begin

 writeln('Введите первую сторону коробочки');

 readln(x);

 writeln('Введите вторую сторону коробочки');

 readln(y);

 writeln('Введите третью сторону коробочки');

 readln(z);

 writeln('Введите радиус отверстия');

 readln(r);

 d := r * 2;

 if (sqrt(x * y * z)

 else writeln('Коробочка не пройдет в круглое отверстие радиуса ', r);

 readln;

end.

(358 баллов)