ПОМОГИТЕ!!!!!!! ПЖПЖПЖПЖППЖ СРОЧНО!!!!! Напишите программу, которая в...

0 голосов
32 просмотров

ПОМОГИТЕ!!!!!!! ПЖПЖПЖПЖППЖ СРОЧНО!!!!! Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 6 и не оканчивающихся на 8. Про-грамма должна вывести одно число: количество чисел, кратных 6 и не оканчивающихся на 8.Пример работы программы:Входные данные36181448540Выходные данные 2


Информатика (34 баллов) | 32 просмотров
Дан 1 ответ
0 голосов

var k, n, a, amax: integer;

begin

amax:=0;

readln(n);

for k:=1 to n do

begin

readln(a);

if (a mod 6 = 0) and (a>amax) then

amax:=a;

end;

writeln(amax);

end.

(65 баллов)