Напишите программу, которая 10 раз выводит ** экран ваши имя и фамилию тремя способами:...

0 голосов
406 просмотров

Напишите программу, которая 10 раз выводит на экран ваши имя и фамилию тремя способами: а) for б) while в) repeat…until. Пожалуйста!!! Сегодня сдавать


Информатика (12 баллов) | 406 просмотров
Дано ответов: 2
0 голосов

var i:integer;

   name:string;

begin

 writeln('Введите свое имя');

 readln(name);

 writeln('Способ через For: ');

 for i := 1 to 10 do

   write(name + ' ');

 i := 1;

 writeln();

 writeln('Способ через While: ');

 while i < 11 do begin

   write(name + ' ');

   i := i + 1;

 end;

 i := 1;

 writeln();

 writeln('Способ через repeat..until: ');

 repeat

   write(name + ' ');

   i := i + 1;

 until i > 10;

end.

(463 баллов)
0

а там где написано введите свое имя надо свое имя писать? или так же переписать?

0

Извините, помогите пожалуйста с моим вопросом по информатике. Очень.очень буду благодарна

0 голосов

Ответ:

Через WHILE:

var s: string;

var i: integer;

begin

write('Введите ваше имя: ');

readln(s);

i:=1;

while (i

writeln(s);

i:=i+1;

end;

end.

Через REPEAT:

var s: string;

var i: integer;

begin

write('Введите ваше имя: ');

readln(s);

i:=1;

repeat

begin

writeln(s);

i:=i+1;

end;

until (i>10);

end.

Через FOR:

var s: string;

var i: integer;

begin

write('Введите ваше имя: ');

readln(s);

for i:=1 to 10 do writeln(s);

end.

(2.5k баллов)
0

а там где написано введите свое имя надо свое имя писать? или так же переписать?

0

Так все переписывай

0

Ничего писать не нужно. Вы просто копируете решение в Pascal и запускаете программу, и уже там вводите имя

0

Если решение требуется "на листочке", то просто переписывайте без изменений

0

Извините, помогите пожалуйста с моим вопросом по информатике. Очень.очень буду благодарна