написать программу ** языке программирования в среде разработки Pascal. Ввести три числа,...

0 голосов
86 просмотров

написать программу на языке программирования в среде разработки Pascal. Ввести три числа, если они отрицательные(каждое, но не одновременно) , то напечатать их модули, иначе их квадраты​


Информатика (14 баллов) | 86 просмотров
Дан 1 ответ
0 голосов

Также прикрепляю код во вложении.

===PascalABC.Net===

program brainly;

var

  num1, num2, num3 :integer;

begin

 Write('Введите три числа: ');

 ReadLn(num1, num2, num3);

 Write('Первое число: ');

 if num1 < 0 then

   WriteLn(abs(num1))

 else WriteLn(sqr(num1));

 

 Write('Второе число: ');

 if num2 < 0 then

   WriteLn(abs(num2))

 else WriteLn(sqr(num2));

 Write('Третье число: ');

 if num3 < 0 then

   Write(abs(num3))

 else Write(sqr(num3));

end.  

(1.7k баллов)