Напишите программу нахождение третьего по величине элемента массива.

0 голосов
67 просмотров

Напишите программу нахождение третьего по величине элемента массива.


Информатика (166 баллов) | 67 просмотров
0

максимальный третий

0

третий по величине нужен, так?

0

Могу глупый способ ток на паскале предоставить, для чего-то годного думать придётся)

0

24067 если такие числа, например, должно выводить 4

0

да

0

Питон

0

А на чём можешь?

0

Не, соре, я не могу на паскале, долго разбираться с его синтаксисом

0

Давай хоть что-то)

0

давай

Дан 1 ответ
0 голосов

Ответ:

program Pascal;

const n=10;

Var i,max,max2,max3: Integer;

m: array[1..10] of integer;

Begin

m[1]:=random(10);

max:=m[1];

max2:=m[1];

max3:=m[1];

For i:=2 to n do  

begin

m[i]:=random(100);

write(m[i]:4);

end;

For i:=1 to n do  

begin

if (m[i]>max) then  

begin

max3:=max2;

max2:=max;

max:=m[i];

end

else if (m[i]>max2) then  

begin

max3:=max2;

max2:=m[i];

end

else if (m[i]>max3) then  

begin

max3:=m[i];

end;

end;

writeln();

writeln(max3);

End.

(2.5k баллов)
0

В строке 10 пишет неожиданный символ ' '

0

После слова "do" есть пустой символ, удалите его там и везде в остальных местах, где требуется

0

Ошибка тут выдается For i:=2 to n do  

0

А что надо поменять?

0

Удалите все пустые символы. К сожалению, сервис изменяет некоторые символы и при копировании компилятор на них "ругается"

0

Также пишет

0

Попробуйте теперь

0

спасибо большое