** языке программирования Python напишите программу,решающую следующую задачу:напишите...

0 голосов
96 просмотров

на языке программирования Python напишите программу,решающую следующую задачу:напишите функцию calc,которая принимает 3 аргумента: первые два- это числа а третий операция которая должна быть произведена над ними.Если третий аргумент + то сложить их если - то вычесть если * то умножить если / то разделить в любом другом случае необходимо вывести фразу не известная операция


Информатика (12 баллов) | 96 просмотров
Дано ответов: 2
0 голосов

Ответ:

def welcome():

 print('Введите ваше имя!')

 name = input()

 print('Введите вашу фамилию!')

 surname = input()

 print(' ')

 print('{0} {1}, мы рады приветствовать Вас!' .format(name, surname))

 print(' ')

welcome()

def arithmetic():

 print(' ')

 print('Выберете выполняемую операцию: "+" - для сложения, "-" - для вычитания, "/" - для для деления, "*" - для умножения')

 print(' ')

 operation = input()

 print('Введите первое число:')

 number1 = int(input())

 print('Введите второе число:')

 number2 = int(input())

 if operation == '+':

   result = number1 + number2

   print('Ваш результат:', result)

 elif operation == '-':

   result = number1 - number2

   print('Ваш результат:', result)

 elif operation == '/':

   result = number1 / number2

   print('Ваш результат:', result)

 elif operation == '*':

   result = number1 * number2

   print('Ваш результат:', result)

 else:

   print('"Неизвестная операция"')    

arithmetic()

print(' ')

print('Желаете ли вы ещё воспользоваться калькулятором?')

print('Введите Y - если Да, или N - завершить работу')

answer = input()

if answer == 'Y' or 'y':

 arithmetic()

elif answer == 'N' or 'n':

 print('Досвидули мэн!')

else:

 print('Неверный символ')

Объяснение:

(125 баллов)
0 голосов

def calc(a,b,operation):

   if operation == "+":

       print("{} + {} = {}".format(a,b,a+b))

   elif operation == "-":

       print("{} - {} = {}".format(a,b,a-b))

   elif operation == "*":

       print("{} * {} = {}".format(a,b,a*b))

   elif operation == "/":

       print("{} * {} = {}".format(a,b,a*b))

   else:

       print("не известная операция")

   

a = int(input("Введите 1 число: "))

b = input("Введите операцию: ")

c = int(input("Введите 2 число: "))

calc(a, c, b)

(1.5k баллов)