1.написать программу которая вводит(и выводит ** экран) массив из 27 целых чисел...

0 голосов
68 просмотров

1.написать программу которая вводит(и выводит на экран) массив из 27 целых чисел используя датчик случайных чисел (randomize) После обработки массива программа выводит на экран элементы,кратные числу N2.Дан целочисленный одномерный массив из 35 элементов,заданных с помощью датчика случайных чисел(randomize)После обработки массива программа выводит на экран номера элементов,которые равны 4​


Информатика (12 баллов) | 68 просмотров
0

На Pascal ABC надо?

0

да

0

Если что-то не понятно, сообщите.

0

а,почему это 2 одинаковых программы?

0

Извеняюсь. сейчас исправлю

Дан 1 ответ
0 голосов

Задача 1.

program zad1;

var i,n: integer; a: array [0..26] of integer; b: string;

begin

Randomize;

write('Введите N = ');

readln(n);

for i:=0 to 26 do begin

a[i]:=random(0,100);

if (a[i] mod n)=0 then

b:=b+a[i]+' '

end;

writeln('Массив до обработки ',a);

write('Числа кратные ',n,' - ',b)

end.

Задача 2

program zad2;

var i,n: integer; a: array [0..26] of integer; b: string;

begin

Randomize;

write('Введите N = ');

readln(n);

for i:=0 to 26 do begin

a[i]:=random(0,100);

if (a[i] mod n)=0 then

b:=b+a[i]+' '

end;

writeln('Массив до обработки ',a);

write('Числа кратные ',n,' - ',b)

end.

(127 баллов)
0

program zad2;
var i: integer; a: array [0..34] of integer; b: string;
begin
Randomize;
for i:=0 to 34 do begin
a[i]:=random(0,100);
if a[i]=4 then
b:=b+' '+i
end;
writeln(a);
write('Номера элементов равные 4 -',b)
end.