Какое значение имеет массив в математике и программировании?​

0 голосов
61 просмотров

Какое значение имеет массив в математике и программировании?​


Информатика (24 баллов) | 61 просмотров
Дано ответов: 2
0 голосов

Ответ:Нужны для оперирования множеством однотипных данных с помощью всего лишь одного идентификатора. Могут найти применение в решении практически любых задач. Математика - лишь одна из таких.

(40 баллов)
0 голосов

При запуске программы массив для неё не имеет никакого значения. Он создан только для того чтобы программистам было написать программу.

Пример(он будет на языке С++ но суть думаю будет понятна)

Создадим 5 переменных

int a1 = 1;

int a2 = 2;

int a3 = 3;

int a4 = 4;

int a5 = 5;

И вот для того чтобы вывести нам нужно будет написать

cout << a1 << a2 << a3 << a4 << a5;</p>

Это не удобно по этому программисты придумали массивы.

Создадим массив для 5 элементов

int a[4]; // Так как отчёт начинает с нуля. 0,1,2,3,4

и заполним, а так же выведем его при помощи цикла

for(int i = 1; i<=4; i++){</p>

a[i] = i;

cout << a[i];</p>

}

Код стал намного меньше и намного лучше читабельный.

(915 баллов)