Язык программирования python! Составить программу для вычисления среднего...

0 голосов
969 просмотров

Язык программирования python! Составить программу для вычисления среднего арифметического N произвольных вводимых чисел. Формат ввода: список действительных чисел, вводимых пользователем с клавиатуры. Формат вывода: Среднее арифметическое (действительное число).


Информатика (16 баллов) | 969 просмотров
0

через максимум час принимай роботу

0

а как оформить выход из программы , когда мы ввели все числа, и нам получить среднее арифметическое, что сделать? Или не важно?

0

по умолчанию сделаю так, что если вводишь 0, то вычисляет среднее арифметическое

0

извини, с самим Python что-то не так, когда разберусь, тогда сделаю код

Дан 1 ответ
0 голосов

s = 0

N = int(input('Введите количество чисел в последовательности: '))

for i in range(N):

   a = int(input())

   s += a

print(s/N)

(654k баллов)