Написать программу которая будет переводить биты в килобайты и наоборот ​

0 голосов
174 просмотров

Написать программу которая будет переводить биты в килобайты и наоборот ​


Информатика (14 баллов) | 174 просмотров
Дан 1 ответ
0 голосов

Ответ:

#include

using namespace std;

int main()

{

   float a;

   int b;

   double  c;

   cout<<"Choose mode: 1 - KB to bit, 2 - bit to KB :"; </p>

   cin>>b;

   switch(b)

   {

   case 1:

   cout<<"Enter KByte count :"; cin>>a;

   c = a * 8 * 1024;  

   cout <<a<<" KByte = "<<c<<" bit";</p>

   break;

   

   case 2:

   cout<<"Enter bit count :"; cin>>a;

   c = a /1024/8;  

   cout <<a<<" bit= "<<c<<" KByte";    </p>

   break;

   }

   return 0;

}

Объяснение:

(204 баллов)