Написать программу, которая заполняет массив А[1..50] случайными числами из диапазона...

0 голосов
83 просмотров

Написать программу, которая заполняет массив А[1..50] случайными числами из диапазона (-30, 30), подсчитывает сколько раз встречается число 0.


Информатика (12 баллов) | 83 просмотров
Дан 1 ответ
0 голосов

var s, i: integer;

a:array[1..50] of integer;

begin

for i:=1 to 50 do

begin

a[i]:=30-random(61);

write(a[i],' ');

end;

for i:=1 to 50 do

s:=0;

begin

if a[i]=0 then

s:=s+1

end;

writeln('Нулей в массиве = ', s);

end.

(14 баллов)