3. Написать программу для вычисления y для заданного x по формуле y= x^3-3,5x^2+2....

0 голосов
89 просмотров

3. Написать программу для вычисления y для заданного x по формуле y= x^3-3,5x^2+2. (Знак - ^ - возведение в степень). Протестировать программу при x=0; x=1; x=13,8; x=-0,5; x=100,35


Информатика (15 баллов) | 89 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

#include < iostream >

#include < cmath >

using namespace std;

double func(double x)

{

   return pow(x,3) - 3.5 * pow(x,2) + 2;

}

signed main() {

   ios_base::sync_with_stdio(0);

   cin.tie(0);

   cout.tie(0);

   double x;

   cin >> x;

   cout << func(x);</strong>

}

(688 баллов)
0

это точно правильно?

0

запусти проверь

0

все правильно спасибо