1)Написать пргравмму( программный код) подсчёта количество символов в слове. 2)...

0 голосов
66 просмотров

1)Написать пргравмму( программный код) подсчёта количество символов в слове. 2) Написать программу (программный код) определяющую, какая из двух фамилий длиннее. Фамилии имеют разную длину.​


Информатика (20 баллов) | 66 просмотров
0

Какой это язык?

Дан 1 ответ
0 голосов

Не знаю на каком языке надо было, но сделал на языке Pascal

1.

var s:string;

k,i:integer;

begin

 readln(s);

 k := length(s);

 writeln(k);

end.

2.

var a,b:string;

i:integer;

begin

 writeln('Введите первую фамилию');

 readln(a);

 writeln('Введите вторую фамилию');

 readln(b);

 i:=length(a)-length(b);

 if i>0 then

   writeln('Первая фамилия длиннее')

 else writeln('Вторая фамилия длиннее')

end.

еще как вариант второго номера:

var a,b:string;

i:integer;

begin

 writeln('Введите первую фамилию');

 readln(a);

 writeln('Введите вторую фамилию');

 readln(b);

 i:=length(a)-length(b);

 if i>0 then

   writeln('Фамилия ', a, ' длиннее фамилии ', b)

 else writeln('Фамилия ', b, ' длиннее фамилии ', a)

end.

(36 баллов)