Составьте программу для решения задачи ** языке Pascal: 1. Найти значение функции а=....

0 голосов
31 просмотров

Составьте программу для решения задачи на языке Pascal: 1. Найти значение функции а=. Обратите внимание, что выражение записано под знаком корня, значит должно выполняться определенное условие. Значения переменных ввести с клавиатуры. 2. Ввести две переменные и найти разность большей и меньшей из них. Рассмотреть оба случая, т. е. большей может быть и одна и другая переменная. Переменные нужно сравнить и выполнить вычисления, когда одна из них больше, иначе – вторая будет больше. Ввести также дополнительную переменную, которая будет обозначать результат вычисления.


Информатика (33 баллов) | 31 просмотров
Дан 1 ответ
0 голосов

Ответ:

Задача 1:

program P1;

var a,b: real;

begin

write('b = '); readln(b);

if 32 - b < 0 then writeln('error') else begin

a := sqrt(32 - b);

writeln(a:0:4);

end;

end.

Задача 2:

program P2;

var a,b,result: real;

begin

write('a = '); readln(a);

write('b = '); readln(b);

if a > b then result := a - b else result := b - a;

writeln(result:0:4);

end.

(654k баллов)