написать программу ** языке программирования Паскаль которая будет сравнивать 5 чисел...

0 голосов
31 просмотров

написать программу на языке программирования Паскаль которая будет сравнивать 5 чисел между собой и выводить наименьшее​


Информатика (14 баллов) | 31 просмотров
Дан 1 ответ
0 голосов

Код:

program Hello;

var a,b,c,d,e, result : Integer;

function min(a,b : Integer) : Integer;

begin

if(a > b) then min := b else min := a;

end;

begin

a := 1;

b := 2;

c := 3;

d := 4;

e := 5;

result := min(min(min(a,b), min(c,d)), e);

writeln(result);

end.

(46 баллов)