Написать программу Pascal abc В шкатулке хранится разноцветный бисер (или бусины). Все...

0 голосов
586 просмотров

Написать программу Pascal abc В шкатулке хранится разноцветный бисер (или бусины). Все бусины имеют одинаковую форму, размер и вес. Бусины могут быть одного из N различных цветов. В шкатулке много бусин каждого цвета. Требуется определить минимальное число бусин, которые можно не глядя вытащить из шкатулки так, чтобы среди них гарантированно были две бусины одного цвета. Входные данные Входной файл INPUT.TXT содержит одно натуральное число N - количество цветов бусин (1 ≤ N ≤ 109). Выходные данные В выходной файл OUTPUT.TXT выведите ответ на поставленную задачу.


Информатика (24 баллов) | 586 просмотров
0

А как подразумевается найти какое-то количество бусин, если оно не дано? Может быть, в шкатулке бесчисленно множество бусин

0

Прошу прощения, не до конца понял условие. Сейчас напишу ответ

0

привет можешь еще раз решить пожалуйста

0

мои мысли
Допустим n = 3 // кол цветов
кол бусин 300
Даже если
100 синих,100 красных,100 зёленых
есть шанс не взять одинаковые.

0

мб так я не знаб

0

но твой ответ неверный снизу

Дан 1 ответ
0 голосов

Ответ:

var N: integer;

var f: text;  

begin

assign(f,'C:\1\INPUT.TXT');

reset(f);

read(f,N);

close(f);

assign(f,'C:\1\INPUT.TXT');

rewrite(f);

write(f,N+1);

close(f);

end.

(2.5k баллов)
0

привет можешь еще раз решить пожалуйста
мои мысли
Допустим n = 3 // кол цветов
кол бусин 300
Даже если
100 синих,100 красных,100 зёленых
есть шанс не взять одинаковые.
мб так я не знаб
но твой ответ неверный снизу

0

все не надо

0

Если кол-во цветов - 3, то взяв 4 бусины, обязательно среди них будут две одинаковые.