ДАЮ 100 БАЛЛОВ!Напишите программу,которая получает два случайных числа и находит...

0 голосов
37 просмотров

ДАЮ 100 БАЛЛОВ!Напишите программу,которая получает два случайных числа и находит сумму,разность,произведение и сумму их квардратов на оснлве даннтй задачи​


image

Информатика (197 баллов) | 37 просмотров
Дан 1 ответ
0 голосов

Ответ:

Объяснение:

program XandY;

const

rndlim=50;

var

x, y : integer;

begin

x:=random(rndlim);

y:=random(rndlim);

Writeln('x=',x,' y=', y);

Writeln('x+y = ',x+y);

Writeln('x-y = ',x-y);

Writeln('x*y = ',x*y);

Writeln('x^2 + y^2 = ',sqr(x)+sqr(y));

end.

Запуск:

Free Pascal Compiler version 2.6.2-8 [2014/01/22] for x86_64

Copyright (c) 1993-2012 by Florian Klaempfl and others

Target OS: Linux for x86-64       

Compiling main.pas                

Linking a.out                     

16 lines compiled, 0.2 sec

x=27 y=29                          

x+y = 56                          

x-y = -2                          

x*y = 783                           

x^2 + y^2 = 1570

(1.4k баллов)
0

мне и тебе так легче будет

0

Напишите программу, которая генерирует случайное четырехзначное число и находит сумму его цифр.Ну вот, типо такая задача

0

у меня нет вк

0

жаль, а почта?

0

Посмотри у меня в профиле вопрос

0

Дам ЛУчший ответ и 5 звезд

0

Ну и спасибо разумеется

0

Ау

0

Помоги пожалуйста, напиши утром,ладно?

0

ищи вопрос у меня в профиле,1 вопрос