СРОЧНО ИНФОРМАТИКА 9 КЛАСС Работа с системой программирования ** языке Паскаль...

0 голосов
52 просмотров

СРОЧНО ИНФОРМАТИКА 9 КЛАСС Работа с системой программирования на языке Паскаль Напишите программу для реализации следующего сценария: • целочисленный массив заполняется случайными числами (размерность массива и числовой диапазон определите самостоятельно); • выводится сообщение «Заполненный массив»; • с новой строки выводятся элементы массива в строку через пробел; • выводится сообщение «Введите значение числа К»; • запрашивается ввод с клавиатуры целочисленного значения числа К; • выводится сообщение «Элементы массива, кратные К»; • осуществляется поиск в массиве элементов, кратных числу К; • выводятся элементы массива, кратные числу К.


Информатика (12 баллов) | 52 просмотров
Дан 1 ответ
0 голосов

Ответ: Программа рабочая, проверена.

Program zadacha;

var  

 a: array [1..50] of integer; // размерность массива = 50

 i,k: integer;

begin

begin

 for i:=1 to 50 do

   a[i] := Random(100); // числа от 0 до 100 будут присутствовать в массиве

 writeln('Заполненный массив: ');

 for i:=1 to 50 do

   write(a[i],' '); end; // выводим массив на экран до проверки

writeln; //новая строка

writeln('Введите значение числа K: '); readln(k);

writeln('Элементы массива, кратные K:');

for i:=1 to 50 do

if (a[i] mod k = 0) then write(a[i],' ');  

end.

Объяснение:

i - порядковый номер элемента

a - сам массив

k - вводимое число

В остальном оставила комментарии.

Размерность массива и его диапазон указан в программе числами, т.к. в задаче не было вопроса о вводе элементов или вводе размерности.


image
(542 баллов)
0

большое спасибо

0

Пожалуйста))