Напишите программу ** языке Pascal. Дано натуральное число A, в записи которого нет...

0 голосов
34 просмотров

Напишите программу на языке Pascal. Дано натуральное число A, в записи которого нет нулей. Требуется найти минимальное двузначное число, которое можно увидеть в записи числа A. Например, для числа 815943 ответом будет 15.​


Информатика (200 баллов) | 34 просмотров
Дан 1 ответ
0 голосов

===Pascal ABC.Net===

program brainly;

var

 number, min, temp :integer;

begin

 min := 100;

 Write('Введите число без нулей: ');

 ReadLn(number);

 while number <> 0 do

 begin

   temp := number mod 100;

   if (temp < min) and (temp div 10 <> 0) then min := temp;

   number := number div 10;

 end;

 Write('Минимальное двузначное число: ', min);

end.

(1.7k баллов)