Написать программу, которая из слова «информатика» получает и выводит ** экран слово...

0 голосов
171 просмотров

Написать программу, которая из слова «информатика» получает и выводит на экран слово «марка». Подсказка к решению: Слова марка состоит из трех кусочков которые мы можем получить из слова «информатика»: ма, р, ка. Надо получит эти три части с помощью команды copy и затем сложить их. ма – copy (a,6,2) (кусочек берем из слова а= «информатика», буква м стоит на 6 месте, в кусочке 2 буквы) Program slova; Var a, b: string; Begin a:=’информатика’; b:= copy (a,6,2) + copy (a,5,1) + copy (a,10,2); WriteLn (b); End.


Информатика (14 баллов) | 171 просмотров
Дан 1 ответ
0 голосов

Ответ:

По идеи, строки в Паскале являются одномерными массивами, легче просто присвоить второй строке символы из первой строки:

b:= a[6]+a[2] ...

(34 баллов)
0

Как полностью будет написана программа?
Сможешь написать пожалуйста?