Напишите программу формирования и вывода массива размером 6*3, каждые три...

0 голосов
46 просмотров

Напишите программу формирования и вывода массива размером 6*3, каждые три последовательных элемента в строке которого составлены по следующему правилу:
1-й ― равен квадрату суммы текущих индексов, увеличенному на 5
2-й — равен целой части квадратного корня из предыдущего элемента;
3-й ― равен целой части частного от деления двух предыдущих элемента.


Информатика (285 баллов) | 46 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

1)
var a:array[1..100,1..100] of Real; i,j:integer; n,m:integer; begin write('Rows='); readln(n); write('Cols='); readln(m); for i:=1 to n do begin for j:=1 to 2 do begin write('[',i,',',j,']='); readln(a[i,j]); end; For j:=3 to m do a[i,j]:=a[i,j-1]+a[i,j-2]; end; For i:=1 to n do begin for j := 1 to m do write (a[i,j]:8:3); writeln; end; readln; end.
2) 
var a:array[1..6,1..3] of Real; i,j:integer; begin Randomize; for i:=1 to 6 do begin j:=1; a[i,1]:=sqr(i+j); a[i,2]:=random(18)-9; a[i,3]:=a[i,1]/2+a[i,2]/2; For j:=1 to 3 do write(a[i,j]:8:1); writeln; end; readln; end.
Но это на языке паскаль я фиг знает какой тебе нада тут два варианта

(166 баллов)