Даю 50 баллов. Помогите написать программу ** С++

0 голосов
28 просмотров

Даю 50 баллов. Помогите написать программу на С++


image

Информатика (161 баллов) | 28 просмотров
0

Это с использованием enum? Есть образец?

0

Да. Я уже не могу фото прикрепить. Enum constant_set { csconstant1 = 0. И тд} c_set; Дальше там будут switch, case...

Дан 1 ответ
0 голосов

Ответ:

#include

using namespace std;

enum myenum { const1 = 5, const2 = 4, const3 = 3, const4 = 2, const5 = 1, const6 = 0 };

int main() {

 int a;

 cin >> a;

 switch (a)

 {

 case const1:case const2:case const3:

  cout

  break;

 case const4:case const5:case const6:

  cout

  break;

 default:

  cout << "Error!";</p>

  break;

 }

}

Объяснение:

(50 баллов)