ЗАДАНИЕ ** ПАСКАЛЕ: написать программу и найти сумму целых чисел от 40 до 120, кратных 11

0 голосов
26 просмотров

ЗАДАНИЕ НА ПАСКАЛЕ: написать программу и найти сумму целых чисел от 40 до 120, кратных 11


Информатика (131 баллов) | 26 просмотров
Дано ответов: 2
0 голосов

Ответ:

PascalABC.NET 3.5.1.2290 + .NET Framework 4.7.1

begin

   Range(40, 120).Where(p -> p mod 11 = 0).Sum.Println;

end.

(1.6k баллов)
0

Извините, можно как-то по другому написать, у меня другая Паскаль, нету таких команд. Pascal N-IDE

0

Может просто не стоит использовать компиляторы, использующие диалект, поддержка которого прекращена более 10 лет назад?

0

Я просто не могу скачать PascalABC.NET, ибо комп стар, ни в какую не качает, а в телефоне нету, да и мало памяти

0

program sum;
var i,s:integer;
begin
s:=0;
i:=0;
for i:=40 to 120 do
begin
s:=s+i;
end;
writeln(s);
end.

0 голосов

Ответ:

Объяснение:

program sum;

var i,s:integer;

begin

 s:=0;

 i:=0;

 for i:=40 to 120 do

 begin

     s:=s+i;

 end;

writeln(s);

end.

(70 баллов)
0

Спасибо большое)

0

это не кратных,ща допишу

0

program sum;
var i,s:integer;
begin
s:=0;
i:=40;
for i:=40 to 120 do
begin
if(i mod 11=0)then
s:=s+i;
end;
writeln(s);
end.

0

Спасииибо)